Symfony 2.0 va adopter PHP 5.3

0
02619432-photo-logo-sensio.jpg
Développé par le pôle 'Labs' de l'agence interactive française Sensio, le framework Symfony dans sa prochaine mouture majeure, la 2.0, sera compatible avec le langage PHP 5.3 sorti cet été.

Toutefois, Symfony ne fait pas une croix sur PHP 5.2 et les entreprises utilisatrices des versions 1.3 et 1.4 de Symfony, structure de développement d'applications, pourront toujours bénéficier de trois à cinq ans de support, par la communauté ou par Sensio Labs respectivement.

Les entreprises qui souhaitent bénéficier des dernières évolutions de PHP 5.3 (support des espaces de noms, fermetures, résolution statique à la volée...) et d'une plus grande interopérabilité entre frameworks, devront patienter jusqu'à la sortie fin 2010 de Symfony 2.0.

« De nombreux développeurs décident d'utiliser les meilleurs composants issus des différents frameworks ; ainsi, il n'est pas rare qu'un projet sous Symfony intègre des bibliothèques du Zend Framework », souligne dans un communiqué Fabien Potencier, co-fondateur de Sensio Labs et développeur majeur de Symfony.

A noter : la communauté de développeurs pourra accéder à la version alpha de Symfony 2.0 dès février prochain lors de la seconde édition de Symfony Live.
Vous êtes un utilisateur de Google Actualités ou de WhatsApp ? Suivez-nous pour ne rien rater de l'actu tech !
google-news

A découvrir en vidéo

Haut de page