Vous pourrez bientôt redonner vie à votre vieil iPad grâce à Linux

Mathieu Grumiaux
Publié le 05 juin 2022 à 10h34
© Josh Sorenson
© Josh Sorenson

Ce projet n'en est qu'à ses balbutiements mais pourrait à terme redonner un second souffle à des tablettes décrites comme obsolètes par Apple.

Bon nombre d'utilisateurs n'ont toujours pas cédé aux sirènes des derniers iPad et continuent d'utiliser leurs iPad mini, iPad Air ou iPad datant parfois de près d'une décennie.

Des modèles jugés obsolètes mais toujours utilisés dans de nombreux foyers

Ces modèles sont peut-être toujours parfaitement opérationnels pour des tâches basiques comme la navigation web ou la lecture de contenus multimédia mais leur fiche technique accuse néanmoins le poids des années.

Les plus vieux iPad ne sont plus supportés par Apple, qui n'apporte plus de mises à jour d'iOS ni de nouvelles fonctionnalités à ses vénérables appareils. Les consommateurs sont invités à remplacer leur modèle par un nouvel iPad plus puissant et équipé de la dernière version.

Si vous ne voulez pas repasser à la caisse et dépenser au minimum 400 € pour remplacer une tablette qui fonctionne toujours, des développeurs ont peut-être une solution qui n'a certes rien d'officiel mais qui pourrait vous rendre de fiers services.

Un développement difficile qui avance à son rythme

Le développeur Konrad Dybcio et un autre passionné se faisant appeler quaack723 sur le web sont actuellement au travail pour installer Linux sur les vieux iPad. Pour ce faire, les deux bidouilleurs utilisent une distribution postmakerOS, basée sur la distribution légère Alpine Linux et adaptée aux appareils mobiles.

Pour réussir à installer Linux, les deux développeurs semblent avoir utilisé une faille de sécurité baptisée « Checkm8 », qui permet de jailbreaker son appareil iOS indéfiniment.

Actuellement, les travaux sont préliminaires et tout ne fonctionne pas correctement. L'installation semble ne fonctionner que sur des appareils équipés des puces Apple A7 et A8, soit des iPad sortis en 2013 et 2014 comme l'iPad Air 2, mais les deux informaticiens expliquent dans une série de tweets qu'à terme même les iPhone ou l'enceinte connectée HomePod, équipée elle aussi d'une puce ancienne, pourraient être compatibles.

Pour l'heure l'installation bloque car le système ne peut pas monter de système de fichiers. Le Bluetooth, l'audio et l'accélération graphique semblent également poser problème mais le travail avance à son rythme et les développeurs semblent sur le coup. D'autres experts pourraient leur venir en aide prochainement pour accélérer le développement.

Source : Ars Technica

Mathieu Grumiaux
Par Mathieu Grumiaux

Grand maître des aspirateurs robots et de la domotique qui vit dans une "maison du futur". J'aime aussi parler films et séries sur les internets. Éternel padawan, curieux de tout ce qui concerne les nouvelles technologies.

Vous êtes un utilisateur de Google Actualités ou de WhatsApp ?
Suivez-nous pour ne rien rater de l'actu tech !

A découvrir en vidéo

Commentaires (0)
Rejoignez la communauté Clubic
Rejoignez la communauté des passionnés de nouvelles technologies. Venez partager votre passion et débattre de l’actualité avec nos membres qui s’entraident et partagent leur expertise quotidiennement.
Commentaires (10)
norwy

Tout projet qui lutte contre l’obsolescence programmée est bon à prendre.

paulposition

Tout a fait; Mais il restera quand même le problème de la batterie de l’Ipad, et si elle donne des signes de faiblesse, son remplacement revient presque aussi cher que de changer de tablette .
Mais il faut saluer cette initiative :+1:

trollkien

Entièrement d’accord, une fois que les périphériques (tablettes, téléphones…) ne sont plus suivis, il devrait y avoir obligation de proposer un patch pour unlock complètement et mettre les drivers spécifiques au produit en libre, afin d’apporter une 2eme vie a des produits tres souvent toujours utilisables.

Exemple, mon pc portable vieillot dont je me sers tous les jours est 3x moins puissant qu’une tablette que j’ai qui sers juste a caler des bouquins

MqcdupouletBasquez

« Tout projet qui lutte contre l’obsolescence programmée est bon à prendre. »

c’est marrant, quand je parlais ici avant tout le monde de Western Digital qui supprimait la possibilité d’accéder à son « Cloud Personnel » donc même pas en rapport direct avec WD, et qu’ils établissent sur leur site une obsolescence programmée de 5 ans, on m’a gentiment dit d’aller me faire Enc… quand j’ai exprimé mon mécontentement ici en disant que c’était normal, que ça se contournait, que je n’avais rien à dire.

Là, pour un produit qui fonctionne toujours, j’ai un ipad 3e génération, le vieux vieux machin, je peux toujours jouer à tous les jeux présent dessus, aller sur internet etc…
AHHHHHHHH Obsolescence programmée, mon dieu quelle horreur !!

Eh oh, on peut toujours l’utiliser comme au départ, simplement, y’a plus de mise à jour possible étant donné qu’il ne pourrait physiquement rien faire tourner de moderne dessus.
Mais de l’époque, rien à changé, tout fonctione.

ChoucrouteGarnie

Comme toujours, le problème avec les appareils mobiles et Linux, ce sont les pilotes matériels, qui sont difficiles à trouver. Toutes les distros Linux qui se sont essayées au mobile ont buté sur ce souci.

didouchk

C’est justement le sens de « obsolète » ! Obsolète ne signifie pas dysfonctionnel, cassé, inutilisable. Larousse pour Obsolescence : « Dépréciation d’un matériel ou d’un équipement avant son usure matérielle ». Comme tu le dis, le matériel fonctionne « mais ne peut rien faire tourner de moderne » => obsolète.
Et cela a trait non pas au matériel obsolète lui-même mais à deux causes principales extérieures :
1 - les nouveaux matériels qui sortent sans cesse et qui déclassent les anciens à vitesse grand V.
2 - l’environnement logiciel et data qui impose de disposer de plus en plus de ressources, rendant l’usage du matériel impossible ou difficile

gamez

Les plus vieux iPad ne sont plus supportés par Apple, qui n’apporte plus de mises à jour d’iOS ni de nouvelles fonctionnalités à ses vénérables appareils.

si c’est comme l’installation de custom rom sur android, ca risque d’en décourager plus d’un.

Comcom1

un iPad sans mise à jour c’est comme une tablette Android, ça existe déjà

wackyseb

Euh, l’idée est donc d’abandonner le système Apple, les applications, l’interconnectivité avec le reste de l’écosystème pour un Linux balbutiant !!!
Alors Linux Oui mais là sur une tablette, euh, non merci.
A la rigueur, on pourrait installer la dernière version d’Android avec le Playstore fonctionnel, je te dirais pourquoi pas mais là, bah non

MqcdupouletBasquez

Alors c’est très juste, mais il y’a une nuance, c’est « programmée »
Tout est obsolète tout le temps.
J’ai une voiture 2019, en 2020 elle est obsolète avec sa suivante.
Je n’ai pas la réalité augmentée sur ma voiture 2019, elle est obsolète.
Pour l’Ipad, on est d’accord, elle est obsolète car les nouveaux logiciels ne fonctionnent pas.

Si l’objectif est de dire : « c’est pas grave, on va forcer », le résultat sera que ça ne pourra pas car le logiciel fait appel à des ressources que l’Ipad n’a pas.

L’obsolescence « programmée », c’est en, référence à @norwy c’est que le matériel est toujours fonctionnel, mais qu’il est fait en sorte qu’il ne puisse plus fonctionner.
C’est par exemple pour une marque de machine à laver d’inclure des pièces d’usures volontairement de basse qualité pour que la réparation soit obligatoire au bout de 3-4-5 ans et que sa réparation soit trop chère pour qu’il soit intéressante.
C’est aussi comme dans le cas de Western Digital, de vendre un produit, ici un disque dur servant de Cloud privé et de dire "vous pourrez vous en servir pendant 5 ans , après quoi, vous ne pourrez plus l’utiliser comme Cloud Personnel mais comme simple disque dur externe.

Non pas à cause là de problème de pièce d’usure, mais qu’ils changent volontairement leur logiciel d’accès au Cloud personnel et qu’ils interdisent l’utilisation de ce logiciel passé le délai.

Ainsi, même si le matériel est toujours fonctionnel, il ne peut plus être utilisé à son usage initial.

Là pour revenir au sujet, l’Ipad est juste « obsolète » car c’est vieux, et lui demander de faire tourner des trucs moderne va juste l’achever.
Mais ce n’est pas programmée, qui peut imaginer faire tourner Diablo Immortal dans des conditions acceptables sur un Ipad 3e génération ?
ça n’a pas de sens.