Communauté Clubic

Site accessible de l'extérieur mais pas en interne

#1

Salut,

j’ai mis en place sur un pc perso au domicile un serveur web. (apache sur ubuntu lucid). Apache démarre sans soucis. Je suis connecté à internet via une freebox.

Si j’accède à mon site depuis l’extérieur de mon réseau (ie chez quelqu’un d’autre, au taf, etc…) il n’y a aucun problème. (http://mon.ip.free.box)

Si j’accède depuis le serveur en question ou une autre machine derrière ma freebox, (http://192.168.1.1) j’ai l’affichage de ma page sans aucun style ni aucune image et si je clique sur un lien j’ai un “forbidden”.

Si j’essaie depuis le serveur en utilisant l’ip externe, je tombe directement sur un “forbidden”.

Du coup, je capte plus grand chose. Je ne pense pas que la configuration d’apache soir en cause, vu que ça marche bien depuis l’extérieur, mais au cas ou, voici le début de la conf de mon vhost

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /home/mon_user/site

Options FollowSymLinks
AllowOverride None

<Directory /home/mon_user/site>
Options -Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all

0 Likes

#2

Quelle distrib, quelle version d’apache ?

Elle est configurée comment ta directive NameVirtualHost ?
T’as un firewall sur ton serveur ?

0 Likes

#3

Ubuntu lucid lynx, apache 2.2.14

NameVirtualHost *:80

Pas de firewall.

0 Likes

#4

192.168.1.1 c’est l’ip de ta freebox non ?
Si oui alors il faut pas utiliser cette ip mais directement celle du serveur quand tu es en interne. Sur une freebox, la redirection de port ne fonctionne que depuis l’interface WAN (celle reliee a la prise telephonique).

0 Likes

#5

Nope, 192.168.1.1 c’est l’ip du pc, pas de la freebox, j’aurais dû le préciser c’est vrai.

J’ai le même problème si je fait http://127.0.0.1…

Ce que je pige pas, c’est que ça doit pas être un soucis de droit vu que depuis une ip extérieure ça marche, et le plus étrange c’est que si depuis un pc sur mon lan j’essaie d’accéder à l’ip wan de ma freebox, (88.xx.yyy.zzz), je tombe directe sur la page d’erreur.

dans ce cas là, il ne log d’ailleurs rien du tout dans access.log ou error.log.
Edité le 26/07/2010 à 12:03

0 Likes

#6

Ta freebox a quelle ip en interne ?

Effectivement ton probleme est etrange…

Faut revenir aux bases dans ce cas :

  • ping depuis le serveur sur son ip lan (192.168.1.1)
  • ping depuis un pc sur le lan vers l’ip lan serveur
  • telnet depuis un pc sur le lan vers le port 80 du serveur

Tu peux mettre ta conf apache complete ? A moins d’avoir 2 vidtualhost qui se bouffent le nez, j’ai du mal a voir d’ou pourrait venir le prob…
Oublie pas les fichiers a droite et a gauche dans conf.d, site-enabled, etc
T’as des erreurs quand tu reload apache ?

Un “apache2ctl configtest” dit quoi ?

0 Likes

#7

La freebox a l’ip 192.168.1.254

le ping du serveur sur son ip 192.168.1.1 répond
pour faire le test sur un autre pc, ça attendra que je sois à nouveau chez moi… Mais à priori c’est bon.

le configtest me dit que la conf est ok, j’ai pas touché au apache2.conf

Le seul message au lancement d’apache est:

apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName

la config du site par défaut: (le seul dans sites-enabled)

<VirtualHost 192.168.1.1:80>
	ServerAdmin webmaster@localhost

	DocumentRoot /home/mon_user/site
	<Directory />
		Options FollowSymLinks
		AllowOverride All
		Order allow,deny
		allow from all
	</Directory>
	<Directory /home/mon_user/site>
		Options -Indexes FollowSymLinks MultiViews
		AllowOverride All
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

0 Likes

#8

Ben la je sais pas… :neutre:
Visiblement ta conf apache semble ok.

C’est bizarre que t’as pas de logs quand tu tentes une connexion depuis le lan. T’en as depuis le wan, c’est ca ?

T’as regardé les logs systeme ?

Vu que la conf reseau de ta machine semble OK, la conf apache aussi, je vois qu’un element exterieur comme une firewall pour bloquer. Je vois pas ce que ca pourrait d’autre…

0 Likes

#9

Question Bête et souvent elles aident un peu;
Tu as simplement essayer de rentrer dans la barre d’adresse de ton navigateur xxx.xxx.x.x.x:80
pour lui préciser sur quel port il doit écouter?

0 Likes

#10

Réponse bête: 9 ans plus tard…

0 Likes