Processeur AMD FX - Virtualisation & Emulation avec Windows 8.1 & Windows 10 désactivées

Bonjour,
depuis à peu près juillet 2020, une mise à jour importante de Windows 8.1 & Windows 10 à désactivé la virtualisation des processeurs AMD FX !
Il est maintenant impossible de lancer un émulateur quelconque !

Une piste: https://docs.microsoft.com/fr-fr/windows-server/virtualization/hyper-v/deploy/deploy-graphics-devices-using-remotefx-vgpu#configure-the-remotefx-vgpu-3d-adapter
N’est ce pas une manœuvre de Microsoft pour pousser les utilisateurs changer ou acheter un autre Pc ?
Qui aurait plus d’info pour résoudre ce problème sans devoir changer son Pc ?

Bonjour,

Avant d’accuser Microsoft tu as été dans les paramètres de ton bios pour vérifier que toutes les options de virtualisation étaient bien actives, autre chose HYPER-V III nécessite plus de choses que la version précédente, il y aussi Virtual Box ou VMWARE

hello

Remote FX n’a rien à voir avec les processeurs AMD FX.
Il est certes désactivé pour des raisons de sécurité, mais cela n’a rien à voir ni avec le CPU que utilise, ni même avec la virtualisation « simple ».

Concrètement, qu’est-ce que tu rencontres comme problème ?
Quel message d’erreur ?

Je ne peux plus lancer d’émulateur pourtant dans mon Bios il est activé, ça marchait bien avant.
Je ne vois pas pourquoi d’un coup avec cette mise à voir ou une autre si c’est pas celle-ci ça ne marche plus.
Quand je lance un émulateur j’ai le message:
Sorry, This Application Cannot Be Run Under A Virtual Machine

Il s’agit de quel(s) émulateur(s) ?

As-tu activé l’une des fonctionnalités Windows suivantes :

  • Bac à sable
  • Hyper V ?

Hyper v oui , bac à sable je sais pas ,
c sandboxie et Memu
Mais ça marchait avant c’est ça qui est bizarre
dites moi comment vérifier svp…

Tu as essayé en désactivant l’Hyper-V ?

Si je l’active, je ne peux pas lancer Virtual Box (avec un message d’erreur m’indiquant que Virtual Box ne peut pas utilisé l’accélération de la virtualisation.

J’ai essayé les 2 c’est vraiment windows a cause de cette KB de mise à jour car avant l’installation des mises à jour ça marchait bien !
Faut que je réinstalle tout sans cette mise à jour et éviter qu’elle se remette !
Sinon qui à une solution ???

Bonjour, as-tu vérifié que les logiciels posant problème ne tente pas de se lancer en mode compatibilité ?

c’est à dire « compatibilité » jamais entendus parlé ?!

Clic droit sur le raccourci avec lequel tu lances VirtualBox, puis « ouvrir l’emplacement du fichier », dans la fenêtre de l’explorateur, faire clic droit (sur le raccourci) « propriétés », puis onglet « Compatibilité », puis vérifier qu’aucune case n’est cochée.

Ces options permettent de faire croire à d’anciens programmes qu’ils tournent sur une version antérieure de Windows, ce qui peut parfois aider à résoudre des incompatibilités entre des logiciels conçus pour d’anciennes versions de Windows.

Plus d’info sur le mode de compatibilité de Windows, ici: https://astuce-pc.com/comment-utiliser-le-mode-de-compatibilite-windows-10/?cn-reloaded=1

a ok mais rien à voir j’install bien mes app en 64bit windows

Cela n’empêche pas de juste vérifier que rien n’est coché dans ce panneau.

La virtualisation est bien activée dans le Bios ?
Est-ce que tu utilises d’autres programmes de virtualisation, tels que Virtual Box ?
Si oui, peux-tu le lancer sans problème ?

C’est au lancement de quel programme que tu obtiens ce message d’erreur ?

De ce que j’ai pu voir, il semblerait que cela puisse se produire lorsque HyperV est actif.

Par contre, une question pour être sûr : On est bien d’accord que tu fais tourner Windows nativement et pas via une machine virtuelle ou Bootcamp sur Machintosh ?

Je suis en Windows 8.1 64, je fais tourner MEMU, SandBoxie et DosBox.
Tout marché bien jusqu’a cette mise à jour KB4570006, KB4577066 et KB4580347 !
C’est une condamnation des FX pour qu’on change de machine !

Comme c’est la zone je réinstalle tout sans ses mises à jour qui condamnent la virtualisation des AMD FX !
J’espère que ce genre de chose soit dénoncé et mit au clair par rapport à tous ceux qui sont dans mon cas !