Routeur derriere 4Gbox

Bonjour,
J’ai une connexion via une 4gbox de bouygues. Celle ci possède un seul port ethernet et comme vous vous en doutez j’en ai besoin de d’avantage.
Il est hors de question d’utiliser le wifi donc j’ai opté pour un routeur (que je possédais déjà).
Seulement voilà, je n’arrive pas a configurer les deux ensemble.
J’ai désactivé le DHCP de la box pour que le routeur le prenne en charge.
J’ai bien branché la box sur le port WAN du routeur.
Mais je n’ai pas de connexion sur les machines reliées au routeur.
Pourriez vous me donner les réglages à effectuer sur la box et sur le routeur je vous prie ?
Cordialement.

laisse le dhcp actif sur la 4g box pour que le routeur puisse obtenir son adresse IP.
Tu dois configurer le dhcp du routeur sur un autre sous-réseau que la box (adresse du routeur sur son lan = 192.168.57.1 par exemple)

ton routeur va agir en tant que passerelle IP NAT. Il va obtenir une adresse IP du routeur 4G sur le port wan et il va en distribuer d’autres aux postes connectés à son port lan. Les postes du lan vont toalement ignorer la box.

1 J'aime

Bonjour lithium et merci de t’intéresser à mon soucis.
J’ai suivi tes conseils mais malheureusement ca n’a pas fonctionné. Peut être est ce ma faute je m’explique :
J’ai laissé le DHCP sur la box comme tu me l’as conseillé.
J’ai désactivé celui du routeur et j’ai aussi changé son ip.

J’avais donc ça :
4G box 192.168.1.1 (l’adresse de base que je n’ai pas changée)
Routeur 192.168.2.1 (il a la même que la box par defaut, j’ai choisi celle la mais je ne sais pas si c’est judicieux je n’y connais rien en sous réseau masque etc ).

J’ai branché box sur le port wan du routeur.
A ce moment la je n’ai plus eu accès à rien. Ni le routeur via son adresse 192.168.2.1 (il avait redémarré), ni à la box avec son adresse 192.168.1.1 que j’avais aussi redémarré.

Je me suis dis tu ne peux pas accédé au routeur parce que ton pc n’est plus dans le meme réseau.
J’ai donc changé mon adresse du pc en 192.168.2.5 (au pif peut etre l’erreur vient elle de là).

Mais rien à faire toujours aucuns accès internet ou paramétrage des deux boitiers.

J’ai donc tout repris a 0 et j’ai fais cela.

4G box DHCP activé adresse de la box par defaut 192.168.1.1
Routeur (remis a 0) DHCP activé également avec adresse par defaut 192.168.1.1

Et bien j’ai de nouveau le net mais la box a son adresse IP qui a changé elle est passé à 192.168.2.1 donc c’est bien que le routeur prend le pas sur la box pour ce qui est du DHCP ?

Quoi qu’il en soit je ne suis pas convaincu que ce soit la bonne façon de faire.

Ai je raté quelque chose ? Est ce correct de laisser comme cela ?
Ca fonctionne certes mais si j’avais pu avoir une installation correcte tout en comprenant ce que je fais ca m’aurais bien plu :slight_smile:

il faut laisser le dhcp du routeur actif pour qu’il distribue des adresses sur son propre réseau

la box et le routeur ont deux réseaux distincts.

Le routeur dispose de deux interfaces réseau. l’interface wan qui obtient une adresse ip dynamique de la part de la box (192.168.1.24 par exemple) et l’interface lan à laquelle tu attribue adresse ip fixe, 192.168.2.1, et qui distribue des adresses ip dynamiques en dhcp aux postes qui y sont connectés (192.168.2.*)

le routeur doit être configuré en passerelle NAT entre son LAN et le WAN.
Ou en bridge, la configuration serait simplifiée mais peu de routeurs le permettent (firmware proprio)

C’est une configuration facile sous OpenWRT. Avec un firmware propriétaire, je sais pas.

Sinon pour ton cas précisément tu a utilisé un mauvais outil. Tu aurais pu installer un switch plutôt qu’un routeur. tu ne te serait pas pris la tête comme maintenant.

j’avais pas vu la fin de ton message. Tu semble être tombé par hasard sur la bonne configuration. Il y a maintenant deux sous-réseaux différent ce qui permet aux deux routeurs (la box en est un aussi) de cohabiter

J’ai placé un routeur derriere la box car je le possédais déjà (il me servait de modem 4G avant la box de Bouygues).
Ca fonctionne oui mais je ne suis pas satisfait.
J’essaye de comprendre ce que tu me dis et de faire aussi mais j’ai pas toujours le résultat attendu.
Actuellement avec la configuration que j’ai détaillé plus haut je peux accéder à l’administration du routeur mais plus celle de la box.
Le routeur est un Tp-Link Archer MR200 j’ai une option DHCP relay, est ce le bridge dont tu parles ?
Par contre je dois bien avoué que je ne comprend pas cette histoire de NAT entre le Wan et le lan mais j’imagine que c’est quelque chose de transparent pour l’utilisateur.

Donc là pour que ca fonctionne je dois concrètement :
Laisser le routeur donner une IP à la Box. Chez moi elle doit avoir 192.168.2.1 (je dis doit car je ne peux plus y accéder)
Laisser le routeur donner une IP à mes PC.

Nat = Network address Translation

Ce qui veux dire que le réseau géré par le routeur est transparent pour l’autre routeur en amont.

ta 4Gbox donne l’addresse 192.168.1.23 à ton routeur par exemple.
Ton routeur gère le réseau 192.168.2.1/24
Les requêtes passant des postes connectés au routeur vers la 4GBox seront « traduites », la 4GBox elle ne connait que 192.168.1.23.

Le « bridge » en français « pont Ethernet » passe en dessous de IP. Là c’est le routeur qui disparaît aux yeux de tous les autres équipements. Il agit au niveau Ethernet, on peut appeler ça un genre de switch intelligent. Il n’a techniquement plus besoin d’adresse IP lui-même (sauf pour l’administrer) et c’est donc la 4GBox seule qui gèrera le routage, dhcp etc

Voici un nat :

et des explication sur le bridge :
https://openwrt.org/docs/guide-user/network/wifi/bridgedap

Et un cas ressemblant à ta configuration actuelle :

Merci pour toutes ces informations. Je vais les regarder de plus près.
Je ne sais pas si on peu fermer un sujet ou pas mais je pense qu’on peut dire que mon problème est résolu.
Merci Lithium et merci Clubic

Tu peut éditer le titre de ton sujet pour ajouter « résolu ».
Merci à toi de prendre le temps de nous répondre et remonter ton expérience. :+1: