Kde 3.4 (page 2)

Je ne te conseille pas d’utiliser la source Thac car j’en n’en ai que des retours négatifs. D’ailleur je vais probablement la retirer de la faq mandrake.
Conseil : la 10.2 va bientot sortir avec KDE 3.3.2 et quelques backports du 3.4 je pense. Il sera plus prudent pour quelqu’un de peu expérimenté d’attendre cette version plutot que d’exploser son joli KDE.

jcp==> tu utilise quel version de amarok ? la version 1.2.1 est extremement instable chez moi :confused:

Chez moi, la 1.2.1 fonctionne impec…

Quelqu’un a essayé par Konstruct, ça doit fonctionner avec ca non ?

J’m’en suis servi une fois (y a longtemps, KDE 3.2 j’crois) et ça marche. Tu compile tout de A à Z. Déconseillé aux newb.

J’ai déjà lancer konstruct hier soir et après quelques heures je bloque toujours sur la même erreur …

[cpp]kernel/qpngio.cpp: In function void qt_zlib_compression_hack()': kernel/qpngio.cpp:1243: error:compress’ undeclared (first use this function)
kernel/qpngio.cpp:1244: error: uncompress' undeclared (first use this function) make[5]: *** [.obj/release-shared-mt/qpngio.o] Erreur 1 make[5]: Leaving directory/home/unix/konstruct/libs/qt-x11-free/work/qt-x11-free-3.3.4/src’
make[4]: *** [sub-src] Erreur 2
make[4]: Leaving directory /home/unix/konstruct/libs/qt-x11-free/work/qt-x11-free-3.3.4' make[3]: *** [build-work/qt-x11-free-3.3.4/Makefile] Erreur 2 make[3]: Leaving directory/home/unix/konstruct/libs/qt-x11-free’
make[2]: *** [dep-…/…/libs/qt-x11-free] Erreur 2
make[2]: Leaving directory /home/unix/konstruct/libs/arts' make[1]: *** [dep-../../libs/arts] Erreur 2 make[1]: Leaving directory/home/unix/konstruct/kde/kdelibs’
make: *** [dep-…/…/kde/kdelibs] Erreur 2
[/cpp]

je sens que je vais m’amuser :d je viens de voir un post ou l’on parle d’installer zlib je vais tester ca si vous avez d’autres idées elles sont les bienvenues :wink:

EDIT : Patch trouvé sur le site officiel :wink:

1.2.3 depuis hier :wink: (sinon, pas de souci avec la 1.2.2 dernièrement aussi).

Bon j’ai finalement installé kde de cette façon :

A ajouter en console :

urpmi.addmedia thacs.rpms http://anorien.csc.warwick.ac.uk/mirrors/thac/10.1/RPMS

quitter kde :
lancez la commande en root :

Urpmi kdebase

Patientez 30 minutes et tout fonctionne :d

Bon voila jessai dinstallé kde 3.4 sur ma gentoo mais voila jai cette erreur sur le lavan avan dernier packatge !

[fixed]grep: //usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/libstdc++.la: No such file or directory
/bin/sed: can’t read //usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/libstdc++.la: No such file or directory
libtool: link: //usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/libstdc++.la' is not a valid libtool archive make[4]: *** [noatun_oblique.la] Erreur 1 make[4]: Leaving directory/var/tmp/portage/kdeaddons-3.4.0/work/kdeaddons-3.4.0/noatun-plugins/oblique’
make[3]: *** [all-recursive] Erreur 1
make[3]: Leaving directory /var/tmp/portage/kdeaddons-3.4.0/work/kdeaddons-3.4.0/noatun-plugins/oblique' make[2]: *** [all-recursive] Erreur 1 make[2]: Leaving directory/var/tmp/portage/kdeaddons-3.4.0/work/kdeaddons-3.4.0/noatun-plugins’
make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory `/var/tmp/portage/kdeaddons-3.4.0/work/kdeaddons-3.4.0’
make: *** [all] Erreur 2

!!! ERROR: kde-base/kdeaddons-3.4.0 failed.
!!! Function kde_src_compile, Line 166, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.

[/fixed]

UP

mise a jour, et boum
[fixed]
[lordaj76@ubuntu ~]$ amarok
amaroK: [Loader] Starting amarokapp…
amaroK: [Loader] Don’t run gdb, valgrind, etc. against this binary! Use amarokapp.
amaroK: [Loader] amarokapp probably crashed!
[/fixed]

J’ai aussi des petits messages, mais Amarok se lance et est pleinement fonctionnel :
[fixed][20:00][jcp@phoenix]
[~] > amarok
amaroK: [Loader] Starting amarokapp…
amaroK: [Loader] Don’t run gdb, valgrind, etc. against this binary! Use amarokapp.
QObject::connect: Cannot connect Engine::Base::statusText( const QString& ) to (null)::shortMessage( const QString& )
QObject::connect: Cannot connect Engine::Base::infoMessage( const QString& ) to (null)::longMessage( const QString& )
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for PlaylistWindow/PlaylistWindow
QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
[/fixed]

édit : screenshot

http://jcp.lespotos.com/images/Bureau31032005.jpg

UP

Hum, on dirait que les liens de ton compilateur ne sont pas bons :/.

Tu as relinké les libs avec libtool (comme indiqué un peu partout), après avoir réemergé gcc ?

Pour les gentooistes, j’ai fait un petit hack de kde.eclass, pour que portage update l’appli à emerger d’après la branche 3_4 du cvs de kde. Cela corrige déjà pas mal de bugs mais il y a encore du travail:

[cpp]

# fix the 'languageChange undeclared' bug group: touch all .ui files, so that the
# makefile regenerate any .cpp and .h files depending on them.
cd $S
# cvs hack début =>
KDEBRANCH="3_4"
touch "${S}/cvspass"
export CVS_PASSFILE="${S}/cvspass"
cvs up -r KDE_${KDEBRANCH}_BRANCH
# <= cvs hack fin
debug-print "$FUNCNAME: Searching for .ui files in $PWD"
UIFILES="`find . -name '*.ui' -print`"

[/cpp]

Ne pas oublier de commenter les patchs déjà appliqués dans les ebuild.

Je testerais ça cet été.

voila ce qu’Amarok version 1.2.3 me sort:


amarok
amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
QObject::connect: Cannot connect Engine::Base::statusText( const QString& ) to (null)::shortMessage( const QString& )
QObject::connect: Cannot connect Engine::Base::infoMessage( const QString& ) to (null)::longMessage( const QString& )
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for PlaylistWindow/PlaylistWindow
QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
fennec@Virga ~ $ Very strange! got a DCOPReplyWait opcode, but we were not waiting for a reply!
Very strange! got a DCOPReplyDelayed opcode, but we were not waiting for a reply!
 

nb: je n’ai pas encore eu le tps de pourir ma gentoo vu que la réinstall date de moins de 72h :smiley: