Espace membre :
flechePublicité

8 messages
Filtrer ok

Clavier en francais sur FreeBSD 6.0 ?

Voila quand je choisis KDE comme window manager pas de prob j ai le clavier en francais mais avec Fluxbox que je prefere je suis en qwerty

Comment avoir le clavier en francais ?
 
 
A ce niveau je dirais que ca dépends de la configuration de ton serveur graphique (X) voire de ton environnement graphique (Fluxbox) et non de FreeB proprement dit.
Pour mettre ton clavier en langue française :
au niveau du système FreeB :
Code :
keymap="fr.iso.acc"

dans ton rc.conf devrait faire l'affaire
au niveau du serveur X :
Code :
    Option  "XkbLayout" "fr"

Au niveau de fluxbox :
Je n'en ai pas la moindre idée ! Demande à google ou attend qu'un utilisateur de cet environnement te réponde. Mais essaye d'abord les 2 première solution, car il n'est pas impossible que Fluxbox reprenne la keymap de l'X
 
 
Le prob c est que dans /etc/X11 je n ai aucun fichier de conf genre Xorg.conf voici le ls -al sur /etc/X11 , c est zarb je comprend pas

splissken@SPlisskPort$ pwd
/etc/X11
splissken@SPlisskPort$ ls -al
total 6
drwxr-xr-x 3 root wheel 512 Nov 22 2005 .
drwxr-xr-x 18 root wheel 2048 Jun 6 06:49 ..
drwxr-xr-x 2 root wheel 512 Nov 22 2005 wmconfig
splissken@SPlisskPort$
 
 

si t'as fais un Xorg -configure tu dois avoir dans ton homedir un xorg.conf.new ou .conf

sinon pour les path /etc/X11/xorg.conf ou /usr/X11R6/etc/X11/xorg.conf

de toutes facons si tu as correctement configurer ton xorg, tu dois copier ton xorg.conf dans /etc/X11/ si tu souhaite qu'il s'applique de maniere globale.

Le handbook est ton ami, www.freebsd.org t'offrira ses lumieres

Felicitations pour le passage aux BSD
 
 
J ai pas fais Xorg -configure et ya rien dans les directory que tu dis mais je vais faire ce Xorg -configure et je dirais apres ce qu il en est
 
 
Yes !!!!! Ca marche , aprés avoir fait Xorg -configure j'ai bien eu le fichier xorg.conf.new que j'ai mis dans /etc/X11 en xorg.conf

Puis un petit vi xorg.conf et ajout de l'option ci dessous

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "fr" <---------
EndSection

Merci jfb2 et deathshadow
 
 
pour info je te conseille d'utiliser ee ou lieu de vi, enfin bon faut aimer ee quand on vient de linux et kon fait tout avec vi/vim

Tu comptes installer quoi comme wm ? faudrait soumettre l'idée de faire un sticky genre "howto" pour xorg fr sur freebsd par exemple
 
 
Je suis un adepte de FluxBox donc c'est ce que j'ai installé et a l'install de depart j'ai choisi Kde pour Konqueror
 
 
     
8 messages
Filtrer ok
Vous devez être connecté pour écrire un message !

BE GEEK ! Avec Clubic Logo

flechePublicité