Espace membre :
flechePublicité

21 messages
Filtrer ok

La fonction RECHERCHE sur Windows 7 ne fonctionne plus

Salut,
La fonction RECHERCHE sur Windows 7 ne fonctionne plus; celle en bas à droite dans le menu démarrer et dans l'explorateur en général. Impossible de retrouver une photo, un document, rien du tout !
Le message est "Windows ne parvient pas à accéder au périphérique, au chemin d'accès ou au fichier spécifié. vous ne disposez peut-être pas des autorisations appropriées pour avoir accès a l'élément". Ce message ne s'affiche que pour les recherches, jamais pour autre chose.
Cela fait plusieurs mois que ça dure donc restaurer le système ne sert à rien.
Quelqu'un pourra-il m'aider ? C'est vraiment pas du tout pratique !

Merci d'avance pour vos réponses !!!!
 
 
Bonjour.

Démarrer -> Exécuter , taper optionalfeatures
Regarder si la case Windows Search est bien cochée.

Démarrer -> Exécuter , taper services.msc
Regarder si Windows Search est bien en automatique .

Démarrer -> Exécuter , taper regedit.exe
Déployer cette branche:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\
Si il existe , sur le volet de droite une valeur nommée NoFind ,la supprimer .
Edité le 06/02/2012 à 16:28
 
 
Bonjour,
Merci pour votre réponse si rapide !

J'ai essayé ces 3 options mais autrement, pas dans Exécuter car Exécuter ne fonctionne plus dans Démarrer non plus, même message d'erreur. J'ai fait ça via le panneau de configuration.
- Windows search est bien coché.
- Il est bien en automatique.
- Il n'y a pas la branche HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer. En tout cas pas Policies

Si vous avez d'autres pistes, ça serait génial !
Merci encore
 
 
support.microsoft.com...

www.intowindows.com...
Si l'anglais n'est pas votre tasse de thé , en gros , c'est ceci :
Ouvrir le registre , déployer la branche
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\
Faire un clic droit sur la clé {ef87b4cb-f2ce-4785-8658-4ca6c63e38c6} -> Supprimer .

Il est préférable de créer manuellement un point de restauration avant de supprimer la clé .
 
 
Merci beaucoup !
Je me lance et je vous informe ensuite.

Oops, j'ai parlé trop vite.
Je ne trouve pas la clé ef87b4cb-f2ce-4785-8658-4ca6c63e38c6 à l'endroit indiqué...
 
 
Et le lien support.microft.com... , ça donne quoi ?
Edité le 07/02/2012 à 18:34
 
 
J'ai installé le hotfix mais ça ne change rien...
Je le répète, merci pour votre attention !
Je tape un mot, rien ne se passe, puis si je clique sur "voir plus de résultats" le message "Windows ne parvient pas à accéder au périphérique, au chemin d'accès ou au fichier spécifié. vous ne disposez peut-être pas des autorisations appropriées pour avoir accès a l'élément" s"affiche.

aramara a écrit:
J'ai installé le hotfix mais ça ne change rien...
Je le répète, merci pour votre attention !
Je tape un mot, rien ne se passe, puis si je clique sur "voir plus de résultats" le message "Windows ne parvient pas à accéder au périphérique, au chemin d'accès ou au fichier spécifié. vous ne disposez peut-être pas des autorisations appropriées pour avoir accès a l'élément" s"affiche.
Encore merci
 
 
Faire un clic droit sur Démarrer -> Propriétés ->Menu Démarrer -> Personnaliser

Regarder le paramétrage de Rechercher dans d'autres fichiers et bibliothèques .
 
 
OK, merci !
Ce qui est coché est "inclure les dossiers publics dans la recherche"
 
 
Ouvrir le registre , déployer cette branche :

HKEY_LOCAL_MAHINE\SOFTWARE\Microsoft\Windows Search\

Clic droit sur la clé Windows Search -> Autorisations , regarder quels sont vos droits .
 
 
Merci,
J'y suis allé et j'ai coché les autorisations pour le système, l'utilisateur et l'administrateur.
Rien ne change.
 
 
Démarrer -> Clic droit sur Ordinateur -> Gérer .Déployer
Observateur d'évènements\Journaux Windows\Système -> Effacer le journal , puis sortir de celui-ci .
Faire des recherches de manière à générer des erreurs dans ce dernier, retourner dans le journal Système ,
faire un clic droit sur les messages d'erreurs (ils on un "i" rouge ou jaune) -> Propriétés de l'évènement .
 
 
Merci Foxburry,
J'ai fait comme vous m'avez dit puis j'ai fait des recherches et cliqué sur voir plus de résultats pour que le message "Windows ne parvient pas à accéder au périphérique, au chemin d'accès ou au fichier spécifié. vous ne disposez peut-être pas des autorisations appropriées pour avoir accès a l'élément" s'affiche. Il n'y avait pas de "i" rouge ou jaune quand je suis retourné dans le journal système.
 
 
Télécharger Process Monitor:
technet.microsoft.com...

Malheureusement , il n'existe pas de tutoriel en français:
www.k-state.edu...

Le lancer puis commencer par réinitialiser le filtre en appuyant sur les touches Ctrl et R .

Démarrer et arrêter la capture des processus en cliquant sur l'icône "Loupe" qui se trouve jute en dessous l'onglet

Event (croix rouge = arrêter , pas de croix = démarrer)

Arrêter la capture des processus. Exclure tous les processus sauf Searchindexer.exe , pour cela faire un clic droit

sur un processus -> Exclude -> Process Name , une fois tous les processus exclus . Ajouter SearchIndexer.exer au

filltre : Appuyer sur les touches Ctrl et L , en dessous Display and matching this conditions , mettre

Process Name is SearchIndexer.exe then Include

Cliquer sur Add -> Apply -> OK

démarrer la capture des processus.

Faire une recherche Windows suivie d'un message d'erreur .

Arrêter la capture des processus , dans la colonne Result , regarder si il y' a autre chose que SUCCES

(par exemple ACCES_DENIED) .
Edité le 09/02/2012 à 16:19
 
 
Bonjour,
Je n'arrive pas à exclure tous les processus sauf Searchindexer.exe. Il y a beaucoup trop de processus je crois.
Je vous avoue que mes capacités en informatique me semblent bien limitées, là...
 
 
Les processus se répètent , exemple , il va y avoir plusieurs svchost.exe , il suffit d'en exclure un , puis tous autres

suivront , idem pour explore.exe , etc..
 
 
amara,

si toutefois ton problème n'est toujours pas résolu, je t'apporte une ultime solution qui, à mon avis, devrait mettre fin à tes ennuis...lol

Il est fort probable aramara que l'index de programmes et de fichiers dans lesquels Windows Search effectue son analyse ait été endommagé ou supprimé par erreur...

Donc :

Démarrer / Panneau de Config / Options d'indexation / Avancé / Reconstruire

Cela doit prendre ± une vingtaine de minutes mais le résultat devrait être convaincant.

@+ bye.
Edité le 23/02/2012 à 23:39
 
 
Bonjour,
Je m'étais absentée et me revoilà.
Merci de t'intéresser à mon problème.
J'ai bien cherché (sans pouvoir utiliser le mode "recherche") et je ne sais pas où se trouve options d'indexation dans le panneau de configuration.
Pourrais-tu me guider ?
Merci
 
 
Merci, j'ai réussi.
Mais ça ne fonctionne toujours, pas, le message "Windows ne parvient pas à accéder au périphérique, au chemin d'accès ou au fichier spécifié. vous ne disposez peut-être pas des autorisations appropriées pour avoir accès a l'élément" s'affiche.
Merci pour votre aide.
 
 
Je me permets de relancer le sujet car je fais face au même problème sous W7 depuis plusieurs mois (et oui...).
Si je coche "exclure les dossiers publics" alors le problème "windows ne parvient pas à accéder au périphérique..." disparait.
Pour autant plusieurs problèmes persistent :
- la fonction recherche ne marche que pour les programmes (par exemple si je tape WORD, il m'affiche le logiciel), mais pas pour les documents
- les options d'indexations restent malheureusement figées et vides... l'option reconstuire n'a aucun effet (voir photos ci dessous).
Merci pour votre aide,

windows search
 
 
     
21 messages
Filtrer ok
Vous devez être connecté pour écrire un message !

BE GEEK ! Avec Clubic Logo

flechePublicité